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Overview

RFTerm allows users to connect to applications running on IBM® 3270, AS/400 and VT hosts from a Microsoft® Windows®
equipped mobile computer over a wireless TCP/IP data network.

RFTerm can be used to directly communicate with host applications. Users can connect and log on to the host applications
without the need for an intermediary device.

Assumptions

This reference guide assumes you have working knowledge of:

Microsoft Windows user interface metaphor and terminology.

Stylus based touch screen navigation terminology.

Basic knowledge of concepts and terms for wireless networking.

Basic operations and requirements of the host applications you want to access with terminal emulation clients.

Conventions Used in this Guide

This guide uses the following typographical conventions:

* All user actions and interactions with the application are in bold, as in Session > Configure.
¢ All text associated with sample or configuration files is presented in a special font:

# This is a sample configuration file for..

#OHHHEE A AR R R A R R R A

[options]

recursion=true

silent=true

checkonly=false

Supported Devices

The following devices support RFTerm:

Tecton (Windows CE 6.0, Windows Mobile 6.5)

Thor VM1 (Windows CE 6.0, Windows Embedded Standard 2009)

Thor VM2 (Windows CE 6.0, Windows Embedded Standard 2009, Windows 7, Windows Embedded Standard 7)
Thor VM3 (Windows Embedded Compact 7, Windows 7, Windows Embedded Standard 7, Windows 10)

Thor VX8 and Thor VX9 (Windows XP, Windows 7, Windows Embedded Standard 2009)

Marathon (Windows XP, Windows 7, Windows Embedded Standard 2009)

Dolphin 70e Black (Windows Embedded Handheld 6.5) as part of the Honeywell Wearable Solution

RFTerm was also supported on several obsolete devices. Keymaps for obsolete devices may be included in Key Maps (page 9-

1).




About RFTerm

Information about RFTerm can be viewed by selecting File > About.

About
RFTerm™ - Windows CE.nek Host Access

@ill Yersion: RETRM=ER xxx
@ Build: i oo
Release: RFTerm

Copyright {c) 2002-2012 Honeywell
v, honesawellaidc, com

Contains software licensed From
Maurtech Corp, Copyright () 1995-
2003, Maurtech Corporation.

Portions based on PUTTY, | o 17y L
by Simon Tatharn - bl

The About screen contains important information about RFTerm, including:

¢ The platform on which RFTerm is installed (Windows XP, Windows CE, etc)
* The revision level of RFTerm

* Copyrights and licensing information. Click the PUTTY License button, if present, to display the PuTTY License (PuTTY is

used for SSH).

Click the OK button to dismiss the About screen.

Feature Highlights
SSH Protocol

When using Secure Shell (SSH), a connection is established to an SSH server and Telnet traffic is tunneled or port for-
warded through the SSH connection. RFTerm supports SSH version 2.

For outgoing traffic from RFTerm:

¢ SSH client (built into RFTerm) listens on a local IP port for Telnet traffic
¢ SSH client encrypts the Telnet traffic and sends it to the SSH server
e The SSH server decrypts the Telnet traffic and forwards the traffic to the Telnet host.

For incoming traffic to RFTerm:

e The SSH server receives Telnet traffic from the host application, encrypts the traffic and sends it to the SSH client (built

into RFTerm)
* The SSH client decrypts the traffic and passes it to the RFTerm Telnet session.

Encryption methods are auto negotiated between the client software (RFTerm) and the SSH server. Supported encryption

methods include:

¢ AES (Rijndael) - 256, 192, or 128-bit SDCTR or CBC
* Arcfour (RC4) - 256 or 128-bit stream cipher

* Blowfish - 256-bit SDCTR or 128-bit CBC

e Triple-DES - 168-bit SDCTR or CBC

* Single-DES - 56-bit CBC

Note: Arcfour and Single DES are not very secure. A warning box is displayed if either of these encryption methods is
selected.

There are two message boxes that may be displayed for SSH server host keys:

* If the key does not exist in the registry, a message box asks if you want to add the key and connect to the SSH server.
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* A message box is displayed if the SSH server host key changes.

If SSH is not enabled, transmission is over an unencrypted Telnet connection.

Multiple Host Sessions

RFTerm supports up to four simultaneous pre-defined host sessions. All sessions run under a single application process.
Interactive, per session configuration settings are maintained. Users may connect with any permutation of 3270, 5250 or
VT host sessions. HotKeys and menu context are available to jump between these sessions.

Swapping Between Sessions

Various HotKeys are defined to allow the user to swap to a specified session or to jump to the next connected session.

A Session Menu can be enabled to display information on configured sessions.

HotSpots

A HotSpot is an invisible field on the mobile client screen where a user can tap with a stylus to execute a function. A
HotSpot allows a user to interact with the host application with minimal need for the special key pads. Instead the user can
directly tap on the text in the display to invoke the desired operation.

Screen Panning

Panning allows an additional row and column on the display by providing an alternative to horizontal and vertical scroll bars.
Imagine the host application screen as a large sheet under the display on the hand-held device. Screen Panning allows
users to “tap” and “drag” this sheet in any direction to move hidden areas of the host display into view on the hand-held
device without the use of scroll bars.

Configurable KeyBar

The configurable KeyBar allows users to customize a set of soft buttons to control and invoke any host specific keys or
emulator operation. Users can select from a set of pre-defined KeyBar templates. In addition they can also configure up to
four custom templates of their own. Users can navigate between a selected set of templates.

SmartPads

All host applications have specific keyboard requirements. The SmartPad is a floating button pad which provides support
for special emulation host keys. Depending upon the current configured host emulation type, the appropriate SmartPad for
that emulation is displayed. The SmartPad supports all the popular 3270, 5250 and VT host keys.

Note: This option is not available devices with a Microsoft® Windows XP, Windows 7, Windows 10, or Windows Embedded
Standard operating system.

Access Control

Access Control allows administrators to prevent users from changing the TE configuration for deployed devices. Adminis-
trators can require a password to change the session configuration and application settings.

Device Lockdown

Lockdown allows administrators to prevent users from exiting the TE client. Lockdown also prevents users from running
any other application on the device.

Configurable Fonts

This option allows users to increase or decrease the font sizes of displayed text.

Color Schemes

Support for color displays. A color scheme is a collection of colors mapped to a set of screen display attributes. Users can
select from pre-defined color schemes or create a custom scheme based upon their preferences. Applications dynamically
detect LCD displays to self configure for a two color scheme (Black on White).




Automatic Login

Users can configure one or more host sessions to automatically launch when the TE application is started. Pre-defined
login scripts can be configured to launch automatically and log into the host system.

Automatic Session Persistence

Latest values of session configuration are automatically saved for every session.

Dynamic Cursor View Modes

Multiple cursor modes are available to support automatic scrolling, so that the cursor / input field is visible. These view
modes are configurable on a per client session basis. The screen display window will “track” and follow the cursor.
Text InputTool

The Text InputTool improves upon the typical Windows CE/Windows Embedded Compact soft keypad by sending complete
text strings to the display window at the current cursor location. A user can cache often-used text strings in the InputTool.

Note: This option is not available devices with a Microsoft® Windows XP, Windows 7, Windows 10, or Windows Embedded
Standard operating system.

Device / LU Name Support

For IBM emulations (3270 and 5250), logical unit device name resource configuration is supported. This is used during
connection negotiations.

Automatic Re-connection

If for some reason the network connection to the host is lost, the user can configure the session to automatically attempt to
re-connect to the host.

Full VT220 Support

This includes support for multinational character sets and NRC support.

VT Line Mode

This is a special optimization for VT host sessions. Data is buffered locally within the device prior to sending it to the host.
Line mode optimizes usage of the network bandwidth and host resources.
VT Answerback String

This is a configurable text string that certain host applications require to identify the mobile client.

HotKeys

Predefined HotKeys, shortcuts, are available to interact with and invoke application operations.

Block Mode

Block mode communication is a communication mode that enables the device to send an entire block of data to the host at
one time. Block mode greatly reduces RF traffic by sending data in this way. Block mode minimizes RF overhead better
than the other modes. Thus, block mode supports more users on an RF channel and allows faster response time.

Local echo is a process that allows each character to display locally at the device as the user presses the keys. The host
does not see these characters until the user presses the [Enter] key.

Note: In most cases, operations using programming tools that include screen painters cannot use block mode
communication. Screen painters or designers usually come with programming tools such as Oracle, Ingress,
Informix, and Powerhouse, which normally use character mode communications.

Programmable Function Keys

User can configure all available function keys, and the 4 arrow keys, to perform text and control character inputs. Control
characters and characters not accessible from the keyboard can be represented using Hat Encoding (page 6-7).

1-4



Printing

User can print the screen for any session using the shortcut key [Ctrl] [Alt] [P], or by sending print commands to the client
from the host in 5250 and ANSI sessions.

Help

User can display frequently used RFTerm shortcut keys and support contact information by pressing [Ctrl] [H].

Double Byte Support

RFTerm supports Simplified Chinese, Traditional Chinese, Korean and Japanese font sets for VT emulations based upon
TELNET data being received in standard DBCS format.

Installation

To verify the version of RFTerm currently installed, see the About RFTerm (page 1-2) panel.

Your device may require special installation procedures. Review the information below for details.

Installation Note

Evaluation copies of RFTerm allow the user to Connect eleven (11) times. The Software License Agreement dialog
appears after each connect request and before the connection is activated. Select either Accept or Reject to continue.
When the counter reaches 0, you cannot use the RFTerm Connect function until the evaluation version of RFTerm is acti-
vated.

Initial Installation (Windows CE, Windows Embedded Compact, or Windows Mobile)

For devices with a Windows CE, Windows Embedded Compact, or Windows Mobile operating system, use the procedures
listed below. RFTerm may already be installed on the device.

1. Launch the RFTerm cab file.
2. Launch RFTerm to complete the installation.

Note: For RFTerm to persist after a device restart, place the RFTerm.cab file in the \System folder.

Upgrading from an Earlier Version of RFTerm

When you upgrade RFTerm to a new release version, you must begin with a clean registry. Use the procedures listed
below for devices equipped with Windows CE, Windows Embedded Compact, or Windows Mobile.

1. Exit RFTerm if it is currently running.

2. Open the registry editor.

3. Delete the entire registry key HKEY_LOCAL_MACHINE\SOFTWARE\LXE\RFTerm.
4. Do not delete the LXE key or any other items under it except RFTerm.

5. Launch the RFTerm cab file.

6. Launch RFTerm to complete the installation.

Installation (All Other Windows Operating Systems)

For devices with a Windows XP, Windows 7, Windows 10, or Windows Embedded Standard operating system, the following
steps must be taken to ensure RFTerm can read and write to the registry before initial installation or upgrading to a newer
revision:

1. Log on as the Administrator.
2. Open the registry editor.

3. Delete the entire registry key HKEY LOCAL MACHINE\SOFTWARE\HSM\RFTerm Or
HKEY LOCAL MACHINE\SOFTWARE\LXE\RFTerm (key name/location depends on equipment type and RFTerm
revision level).”




4. Do not delete the HSM or LXE key or any other items under it except RFTerm.
5. Browse to the location of the RFTermSetupWN.msi file, double-click on the file and follow the setup wizard prompts.

6. Launch RFTerm for the initial time as the administrator. For devices with Windows 7, Windows Embedded Standard 7,
or Windows 10 right click on the RFTerm icon and select Run as administrator.

7. This will create the RFTerm registry with guest privileges.

Quick Start

This section is for advanced users who can comfortably navigate within Windows and Windows CE and are familiar with host
terminal emulation details. Follow these steps to connect to your host application with minimal configuration setup. For details
on various configuration parameters, it is recommended that you read through the following sections.

1.

Make sure the mobile network settings are configured. If you are connecting over wireless LAN, make sure your device is
communicating with the Access Point. If you are connecting via WWAN, make sure your device has an active connection.
Details on configuring the mobile network settings can be found in the reference guide for the mobile device.

. If the RFTerm splash screen does not automatically appear after startup or rebooting, go to Start > Programs, and select

Honeywell RFTerm or double-click the RFTerm icon on the Windows desktop.

. Select Session > Configure from the application menu and select the Host Type that you require. This will depend on the

type of host system that you are trying to connect to; i.e. 3270 mainframe, AS/400 5250 server or VT host.

. Enter the Host Address of the host system to which you wish to connect. This may either be a DNS name or an IP address

of the host system.

. Update the Telnet Port number, if your host application is configured to listen on a specific port. If not, just use the default

Telnet port.

. Select OK.

. Select Session > Connect from the application menu or tap the Connect button on the Command Bar. Upon a successful

connection, you should see the host application screen displayed.

. During the connection process, the following popup dialog appears:

RFTerm Session 1

Q—;’ Connecking ko 100,100,100, 100
on park 23
e :




RFTerm Screen Sizes
The RFTerm screen displays are designed to function on most Windows-based computers, regardless of the physical
screen size.

RFTerm menus and editing parameters, save and exit options are available on-screen, where needed, regardless of the
size of the screen. On-screen they may look or be named differently from one device to the other yet they will perform the
same function when activated.

RFTerm uses a one-quarter screen, switchable
between horizontal or vertical orientation on the
Windows Embedded Handheld equipped Dolphin
70e Black.

Fis S Dace B2 W2 W R = Fin Seaon Dacli L V3 W R B

RFTerm uses a one-quarter screen, horizontally
oriented on the HX2.

Tde tarcann Hinpdey

RFTerm uses a one-quarter screen, vertically
oriented on the Windows CE equipped MX7 Tecton,
MX8 and MX9.

RFTerm uses a one-quarter screen, vertically

oriented on the Windows Mobile equipped MX7
Honeywell Honeywell Tecton, MX8 and MX.

TIF Genalan Nikmlay gY TIF Ganalan fikplay g




Tdn tarcain Dinpdey

RFTerm uses a one-half screen, horizontally oriented
on the MX3Plus, MX3X, VX3PIlus, VX3X and VX6.

Tdw  farcann Hiepdeyg

RFTerm uses a full screen on the Thor VM2, Thor
VM3, VX7, Thor VX8 and Thor VX9.

RFTerm uses a WVGA full screen on the Thor VM1

HoneyWEII and Marathon.

This guide makes the assumption that the user or systems administrator is familiar with Microsoft Windows standard navi-
gation/performance for each of their devices running RFTerm.

Therefore, the sections that follow describe only those Windows capabilities that are unique to RFTerm.

Important Notes

For Devices with a Windows Mobile or Windows Embedded Handheld operating system:

The MenuBar is displayed at the bottom of the Windows Mobile screen and cannot be led to the top of the screen.
By default, the KeyBar is hidden but can be accessed from the MenuBar using the KeyBar icon.

When accessed, the KeyBar is displayed above the MenuBar. Clicking the KeyBar icon again hides the KeyBar.
The ToolBar is not available on devices with a Windows Mobile operating system.

For Devices with a Windows XP, Windows 7, Windos 10, or Windows Embedded Standard operating system:

¢ SmartPads, Text InputTool, and Hide/Display All Bars are not available on devices with a Windows XP, Windows 7 or
Windows Embedded Standard operating system.
e The MenuBar is displayed at the top of the screen for these devices and cannot be led to the bottom of the screen.
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Quick Tips
Screen Panning

* Forall connected sessions (3270, 5250 and VT), you can “tap-and-drag” the display screen in any direction with your
stylus. Just make sure that HotSpots are enabled in Options1 (page 2-6).

HotSpots

e For all connected sessions (3270, 5250 and VT), you can “double tap” anywhere on the screen to invoke an Enter
(or Send) operation.

* To use HotSpots, you can directly tap the function key text string on the display rather than use a SmartPad. Refer
to HotSpots (page 4-10) for details.

Predefined HotKeys (Shortcuts)

¢ Almost every application operation has a HotKey associated with it. HotKeys provide an efficient alternative to
invoke an operation or action. Refer to HotKey Shortcuts (page 4-12).

Readability

* Formore screen real estate, you can minimize the application menu. You can also move open windows to anywhere
on the screen (unless the windows are locked to prevent edit).

* You can select different background, foreground and attribute colors for enhanced visual readability. For mobile
clients with LCD display screens, the default color scheme is automatically detected and configured to “Bright White”
for optimal readability.

Data Input

¢ If you have the same data strings that you input all the time, you can cache it in the data input tool. You can then
“send” the text string to the emulator with a single stylus tap. Refer toText InputTool (page 4-8).

Note: This option is not available on devices with a Windows XP, Windows 7, Windows 10, or Windows Embedded
Standard operating system.

Configurable KeyBar

* The soft KeyBar can be configured to perform most emulator and host operations with a single stylus tap. Refer to
Configurable KeyBar (page 4-4).

Access Control

¢ You can prevent a user from changing the TE configuration by specifying an access password. Refer to Access
Control / Device Lockdown (page 4-11).

Application ToolBar

¢ An integrated ToolBar is provided for touch screen navigation.
¢ Refer to RFTerm ToolBar (page 9-1) to identify the function for the icons that are included in the different application
touch KeyBars.

Miscellaneous

* The RFTerm emulator will automatically save configuration settings for the four most recent sessions, S1 - S4 as
displayed in the menu. The configuration settings are saved in the mobile client registry. Refer to the mobile client
reference guide for instruction.

¢ To launch RFTerm automatically, refer to the reference guide for the device.

e Support tools and procedures are available to provide deployment configurations to self-install and restore
application and mobile client configurations during a cold boot.




1-10



RFTerm Settings

This section describes application wide settings. All these parameters may be set using the application settings dialogs
accessed from the File > Settings application menu. Parameters configured through the File > Settings dialog apply to all ter-
minal emulation sessions.

For Microsoft Windows 7, Windows Embedded 7, and Windows 10:

It is necessary to run to run RFTerm as an administrator when modifying these settings because RFTerm must be able to
access and make changes to the Windows registry.

Rather than selecting to run as administrator each time, right click on the RFTerm icon and select Properties. Tap the
Compatibility tab and check Run this program as an administrator. This modification affects the current user only un-
less Change settings for all users is tapped before changing the privilege level.

Display

The client screen display may be configured to optimize screen available area and readability. These options may be configured
for connected or non-connected host sessions. HotKeys are available to le the options on and off.

-Menu

Display | shortouts | options1 | opti <[ »

[ Hide All Bars [~ | Hide MenuEar
Hide kevEar |:| Hide ToolEar
[ atBottom [ | Hide QL& (I6M)

-Scroll Bars
[ Hide vertical [ | Hide Horiz

I:l Disable Touch
Screen

* From the application menu, select File > Settings.
* A Settings dialog box is displayed.
¢ Choose the Display tab.

Parameters

Menu

ToolBars, KeyBars, Shortcut Keys and Windows Mobile

By default, the ToolBar button function is configured as part of the KeyBar on devices with a Windows Mobile oper-
ating system so the checkbox for the ToolBar does not exist on the Settings > Display tab.

ToolBar buttons can be removed from the KeyBar on devices with a Windows Mobile operating system.

ToolBar buttons can be hidden by using [Ctrl][Shift][K] which makes the entire KeyBar hidden on devices with a
Windows Mobile operating system.

The Hide ToolBar shortcut key [CtrI][Shift][T] is not available on devices with a Windows Mobile operating sys-
tem.

Hide All Bars

Checking this box will hide the file menu, the KeyBar and the ToolBar. Pressing [CtrI][Shift][L] alternates
between the hidden and visible states. This will override each individual item listed below.

Not available on devices with a Windows Mobile operating system.




Disable/Hide MenuBar

Checking this box will hide the MenuBar on devices with a Windows CE or Windows Embedded Compact operat-
ing system. Pressing [CtrI][Shift][M] alternates between the hidden and visible states.

When the MenuBar is hidden, the KeyBar is displayed on the bottom row, where the MenuBar is normally shown.
When MenuBar is led on, the KeyBar is displayed on the row above the MenuBar.

Checking this box disables the MenuBar on devices with a Microsoft Windows XP, Windows 7, Windows 10, or
Windows Embedded Standard operating system.

Note: This parameter is titled Disable MenuBar on devices with a Microsoft Windows XP, Windows 7, Windows
10, or Windows Embedded Standard operating system and Hide MenuBar on devices with a Windows CE,
Windows Embedded Compact, or Windows Mobile operating system.

Hide KeyBar

Checking this box will hide the KeyBar. The default is checked (hide KeyBar). Click the K icon on the MenuBar to
launch the KeyBar. Pressing [CtrI][Shift][K] will alternate between the hidden and visible states.

When the MenuBar is hidden, the KeyBar is displayed on the bottom row, where the MenuBar is normally shown.
When MenuBar is led on, the KeyBar is displayed on the row above the MenuBar.

On devices equipped with Windows Mobile, the ToolBar buttons can be hidden by using [Ctrl][Shift][K] and the
entire KeyBar is hidden on these devices.

Hide ToolBar

Checking this box will hide the ToolBar. Pressing [Ctrl][Shift][T] alternates between the hidden and visible states.
Not available on devices with a Windows Mobile operating system.

(Menu) at Bottom

Checking this box will move the menu to the bottom of the screen. Pressing [Ctrl][Shift][B] alternates the loca-
tion between the top and bottom of the screen.

Note: This option is not available on devices with a Microsoft Windows XP, Windows 7, Window 10, or Windows
Embedded Standard operating system.

Hide OIA (IBM only)

Checking this box will le hiding of the OIA or the Operator Information Area. This option applies only to IBM 3270
and 5250 emulations.

Pressing [CtrI][Shift][O] or [Alt] [T] alternates between the hidden and visible states.
Scroll Bars
Hide Vertical Scroll Bars

Checking this box will hide the vertical scroll bar. Pressing [Ctrl][Shift][V] alternates between the hide and visible
states.

Hide Horizontal Scroll Bars

Checking this box will hide the horizontal scroll bar. Pressing [CtrI][Shift][H] alternates between the hide and vis-
ible states.

Disable Touch Screen

When checked, this option prevents the user from inadvertently moving the cursor via the touch screen. The touch
screen within the RFTerm display portion of the screen is disabled while still allowing RFTerm HotSpots to function
using touch. Items such as scroll bars and menu items still are accessible via the touch screen.

The default value for Disable Touch Screen is “Not Disabled” (blank).




Shortcuts

Keypress shortcuts can be enabled or disabled from the Shortcuts tab.

All shortcut keys can be enabled or disabled at once. Shortcut keys can be disabled or enabled individually as well.

Shortcuts | options1 | optionsz IEEE

[ | Mesxt Session (active o inactive)
rDisable Shortout Keys

< |

| | connect {ctrl+Shift+c)

|:| Decrease Fonk (Cer+Shift+Daown
[ | Disconnect (Ctrl+Shift+0n

[ Toggle HScroll (Ctrl+Shift+H)

|:| Toggle MenuBar (Ckrl+3hift+r)

Select Al

Clear all

From the application menu, select File > Settings.
A Settings dialog box is displayed.
Choose the Shortcuts tab

Parameters
Jump to Inactive Sessions

When the Jump to Inactive Sessions item is selected, the user can use the shortcut key sequence [Ctrl] [Shift] [J] to
jump to an inactive session that has a host name specified. The inactive session remains dormant when discon-
nected, but when it becomes the active session again, it automatically attempts to reconnect and run the Autologin

script.

Disable Shortcut Keys

When the Disable Shortcut Keys item is checked, RFTerm prevents the user from accessing all shortcut keys with the
exception of Session, Configure and Application Exit shortcut keys. This also activates the “Allow Session Shortcuts”

check box. F1, F2, F3, and F4 function keys remain active. Refer to RFTerm ToolBar (page 9-1) for a complete list of
RFTerm shortcut keys.

Buttons

Select All

Click this button to disable all shortcut keys, in the list, at once. Click a shortcut key checkbox to enable the

individual shortcut while the rest remain disabled (checked). The Select All button has no effect on the Jump
to Inactive Sessions checkbox.

Clear All

Click this button to enable all shortcut keys, in the list, at once. Click a shortcut key checkbox to disable

(check) the individual shortcut while the rest remain enabled. The Clear All button has no effect on the Jump
to Inactive Sessions checkbox.




Shortcuts Active Until Disabled

The shortcut is disabled when the checkbox has a check mark. Refer to HotKey Shortcuts (page 4-12) for a com-
plete list of default HotKeys.

Note: Depending on mobile client screen size constraints, the parameter name may be abbreviated based on the

parameter names shown in the list that follows.

Parameter Shortcut Key Description
Configure [CtrI][Shift][N] Configure a host connection
Settings [CtrI][Shift][E] Configure application settings.
Connect [CtrI][Shift][C] Connect to the host

(Manual Reconnect shortcut)
Status [Ctri][Shift][2] Display or hide Status Window.

(Not supported on Windows Mobile)

Decrease Font

[Ctrl][Shift][Down Arrow]

Decrease font size

Disconnect [Ctrl][Shift][D] Disconnect a connected host session
(Manual Disconnect shortcut)

le HScroll [CtrI][Shift][H] Display or hide horizontal scroll bar

le SmartPad [CtrI][Shift][P] Display or hide SmartPad
(Not supported on Windows XP, Windows 7, Windows 10,
or Windows Embedded Standard)

le InputPad [Ctrl][Shift][I] Display or hide Text InputTool
(Not supported on Windows XP, Windows 7, Windows 10,
or Windows Embedded Standard)

le MenuBar [Ctrl][Shift][M] Display or hide MenuBar
(Not supported on Windows XP, Windows 7, Windows 10,
or Windows Embedded Standard)

Move All Bars [Ctrl][Shift][B] Display all bars at the bottom
(Not supported on Windows XP, Windows 7, Windows 10,
or Windows Embedded Standard)

le All Bars [Ctrl][Shift][L] Display or Hide all bars (Menu, Tool, Key)

le ToolBar [Ctrl][Shift][T] Display or Hide ToolBar

le KeyBar [Ctr][Shift][K] Display or Hide KeyBar

le VScroll [Ctrl][Shift][V] Display or Hide vertical scroll bar

Increase Font [Ctrl][Shift][Up Arrow] Increase font size

Next Session

[CtrIl[Shift][J]

Jump to next connected host
(Session Control shortcut)

Scroll Down [Shift][Down Arrow] Scroll down one row

Scroll Left [Shift][Left Arrow] Scroll left one column

Scroll Right [Shift][Right Arrow] Scroll right one column

Scroll Up [Shift][lUp Arrow] Scroll up one row

le Bold [CtrI][Shift][1] le between bold and normal font
Print Screen [Ctri][Alt][P] Print the screen of the active session
Program Help [Ctrl][H] Display frequently used shortcuts
Jump to Session 1 [Ctr][AR][1] Jump to Session 1

Jump to Session 2 [CtrI][AR][2] Jump to Session 2

Jump to Session 3 [CtrI[AR][3] Jump to Session 3

Jump to Session 4 [CtrI][Alt][4] Jump to Session 4




Parameter Shortcut Key Description

Show Session Menu | [Ctrl][Alt][0] Display Session Host Menu (if enabled) over top of a
connected session

Session Save [Ctrl][Shift][S] Invoke the session save dialog

Exit RFTerm

[CtrIl[Shifl[X]

Exit the emulator

le OIA Bar

[CtrI][Shift][O] or [AI[T]

Hide and unhide status bar (OIA)

Advance Down

[Ctrl][Down Arrow]

Scroll down one row segment (see Note below)

Advance Left

[CtrI][Left Arrow]

Scroll left one column segment (see Note below)

Advance Right

[Ctrl][Right Arrow]

Scroll right one column segment (see Note below)

Advance Up

[Ctrl][Up Arrow]

Scroll up one row segment (see Note below)

le Status

[Ctrll[Shiftl[2]

Display or hide status icons

(must be enabled on the Settings > Status tab first)

(Not supported on Windows Mobile, Windows XP, Windows
7, Windows 10, or Windows Embedded Standard)

Note: Depending on the mobile device screen and font size constraints, the segment area used by an Advance
Down, Advance Left, Advance Right or Advance Up key sequence is approximately one-quarter of the total

area available.




Options1

General options may be configured and updated from the Options1 tab.

Note: This tab was previously labeled Options.

Options1 |Opti|:|r-|52 IDDtiI:IFI53 IEEE

Arccess Conkrol
[ Hide Start Menu

|:| Disable App Exit | Exit Mo |

| Config Password |

|:| Confirrn Cisconneck

Enable HokSpaots

Erlarge HatSpats
[ check Metwork Status

[ Disable scan on exit forus

e From the application menu, select File > Settings.
e A Settings dialog box is displayed.
e Choose the Options1 tab

Parameters

Access Control

Hide Start Menu

When the Hide Start Menu item is selected, RFTerm prevents the user from accessing functionalities within the
task bar.

With Windows XP, Windows 7, Windows 10, or Windows Embedded Standard

This feature makes the application full-screen and also disables window resizing.
While this option hides the Start Menu, it cannot prevent the user from accessing the Start Menu via the Win-
dows key.
With Windows Mobile
When the Hide Start Menu / Disable Start Menu item is selected, neither the Start Menu nor the OK button
responds to a stylus tap. Use an Enter keypress to close the Settings and Configure window.
Disable App Exit
When enabled, this option disables the application exit button and the [AIt][X] shortcut key. This prevents the user
from exiting the application.
Exit Now

This button is enabled only when the Disable App Exit option is checked. It allows the administrator to save the
configuration and exit when Disable App Exit is checked. Typical use would be for an administrator to set all con-
figuration settings including a config password and exit the application using this button. Subsequently, users will
not be able to exit the application and the config password will be required to change the configuration.

Config Password

The Config Password button prompts the user for a dialog access password. When a password is set, users must
enter this password prior to viewing and modifying the session and settings configuration. This capability enables
administrators to prevent users from changing the application configuration settings in controlled environments.




Confirm Disconnect
When enabled, the user is prompted before every attempt to disconnect an active session.
Enable HotSpots

Checking this box will enable HotSpots and Screen Panning on mobile clients with touch screens. A HotSpot is a field
on the screen where a user can tap with a stylus to execute a function. This allows a user to interact with a host appli-
cation with minimal need for special keys. Checking this box is a requirement for the Enlarge HotSpots parameter.

For example

A simple example might be the use of F Keys. An operation associated with an F key might be displayed on the screen
as “F1 = Help”. RFTerm automatically detects this as a HotSpot and will simulate an F1 key being pressed on the key-
board when you tap on the F1 text on the screen display. Refer to HotSpots (page 4-10) for further details.

Note: Reprogramming the function keys using the Fn Keys tab under the Configure dialog alters the operation of a
function key HotSpot.

Enlarge HotSpots
Prerequisite:
Enable HotSpots must be enabled (checked).

Checking this box increases the size of the HotSpot area, slightly, radiating from the center of the HotSpot. If a screen
does not have a HotSpot area, this parameter setting is ignored until a screen is presented that has a HotSpot area.
For example, enlarging the HotSpot area may assist clicking the correct HotSpot even if the mobile client is being jos-
tled by outside influences.

When Enable HotSpots is disabled, the Enlarge HotSpots parameter is dimmed and cannot be activated.
Check Network Status
This setting determines if RFTerm continuously monitors the network connection.

Note: This option is not available on devices equipped with a Windows Mobile or Windows Embedded Handheld
operating system.

If the checkbox is checked (enabled) RFTerm polls the network adapter every two seconds to verify the network status.
If the network adapter is not connected, a dialog box is displayed.

Two conditions must be present for network polling to occur:

1. The Check Network Status checkbox must be checked.

2. There must be at least one active session.

RFTerm Metwork Status

Q—; Terminal Cut Of Range!

e

Return ba coverage area.

There is no user input on the popup notification. The popup box is displayed until the network connection is re-estab-
lished and the user is restricted from entering any data into or exiting from RFTerm while the notification is present.
Once network connection is reestablished, the notification automatically is dismissed.

If the checkbox is unchecked (disabled) RFTerm does not monitor the network connection. The Out of Range notifica-
tion is not displayed until a data transmission fails. This is the default selection.




Out of Range of Access Point

=

xg}] Press Retry ko continue, .

Retry | Cancel |

The user is present with a popup dialog. The Retry button attempts to reconnect to the network. The Cancel button
exits RFTerm.

Note: There is no Cancel button if the application is locked down by disabling application exit and/or by hiding the start
menu. You must either re-establish the connection to the host or have the administrator intervene.

Disable Scan On Exit Focus

When checked, this option turns off the scanner when RFTerm is no longer the application in focus. When RFTerm
returns to focus, the scanner is turned back on.

When disabled, the scanner remains active at all times.
The default is disabled.
KeyBars

This button is used to configure the KeyBar. KeyBar configuration consists of both the KeyBar Cycle and any Custom
KeyBars. The KeyBar function keys can be reprogrammed using the Fn Keys tab under the Configure dialog.

Note: The KeyBars button was previously labeled Config Keys.
KeyBar Cycle

A KeyBar is the set of keys visible at one time. The KeyBar Cycle is a collection of KeyBars that can be visible.
The user “cycles” through the collection of KeyBars by tapping the arrow buttons on either end of the current Key-
Bar. Each key on the KeyBar is associated with a host or emulator operation. Users are allowed a maximum of

eighteen KeyBars, four of which can be customized. The same KeyBar may be added multiple times to the Key-
Bar Cycle.

KeyBar Configuration m
KeyBar Cycle | custom Bar |

Base keys
Special Keys
Scroll Kews

add to Above | | Delete |

Base keys @
Special Keys

ToolBar Keys
Scroll Kews

Custom Bar

A Custom KeyBar (Custom Keys 1 through Custom Keys 4) can also be included in the KeyBar Cycle. Tapping
the Custom Bar tab allows the user to configure a custom KeyBar. There are over 180 buttons to choose from,
refer to RFTerm ToolBar (page 9-1) for available choices.




KeyBar Configuration m

KeyBar Cycle | Custorm Bar
ICustu:um kevs 1 EI
Prewvious kKeyBar

Mexk kKewvBar

| Add to Above | | Delete |
Prewvious KeyBar -
Mext KevBar

--Separatar--

To edit a Custom KeyBar

In the KeyBar Cycle tab, add a Custom Bar to the KeyBar Cycle

In the Custom Bar tab, select the Custom Bar that you want to configure
Select the Key or operation that you want to appear on this custom bar
Tap Add to Above. The selected key / operation will appear in the list.
Delete unwanted keys by selecting them and tapping Delete.

You can add up to a maximum of 8 key buttons on each Custom Bar (fewer on some devices). The entry for Pre-
vious KeyBar cannot be removed and must exist in each KeyBar to allow for “cycling” between KeyBars. Typi-
cally, the last key should be Next KeyBar for cycling to the next KeyBar.

One powerful capability of the KeyBar is the ability to associate keys with the Text InputTool. Key entries Input 1
through Input 20 are tied to the corresponding twenty entries in the Text InputTool. Thus if you have a text string
configured in the data input tool, this string can be submitted to the host application by tapping on the Input X key
in a Custom KeyBar. Tapping this key will send the complete text string to the current cursor location. For VT cli-
ent sessions, escape sequences can be added to the Text InputTool text. This allows users to configure custom
escape sequences as required by their host applications.

Escape sequences can be entered into the Text InputTool in the following format:

\e
\n

\r =

\t
\x

DD

Note:

Escape

Newline

Enter or Return

Tab

= Hexadecimal value

The list of keys that are available for a Custom KeyBar includes “Escape”. The Escape icon is identical for

VT Escape and 3270 Escape, both listed in RFTerm ToolBar (page 9-1) icon listing. When setting up a
Custom KeyBar for VT or IBM, and VT Escape or 3270 Escape is required, select the “Escape” icon.




Options2

Determines the behavior of RFTerm in certain circumstances.

Options2 | Options3 | Sounds | Stat 4] »
I:l Respond DOMT encrypk

Focus contral INnrmaI El
Script File I EI
Wedge Mode I EI

Spel Setkings: I

* From the application menu, select File > Settings.
e A Settings dialog box is displayed.
e Choose the Options2 tab
Parameters
Respond DONT encryption
Determines the behavior of RFTerm response to WILL encryption.

¢ When checked, RFTerm responds DONT.
¢ When unchecked, RFTerm responds WONT.

The default is unchecked (WONT).

Focus Control

Determines if RFTerm remains the focus window when another dialog attempts to grab focus.

¢ Normal - RFTerm does not override. (default)

* Foreground - RFTerm forces the focus back to RFTerm if a “Backup Battery Low” dialog grabs focus.
Script File

Note: This option pertains to the Marathon computer with all available operating systems. This parameter has no effect
on other devices.

If Freefloat Link One is not active (or not installed) an error message may be displayed when trying to set this option.

¢ Specify the script file used to determine the Freefloat Link One wedge mode.

* Using Default script.txt - The script file provided with Freefloat Link One is used. Only Keyboard mode may be
selected for the wedge when this script file is used. (default)

¢ Using RFTerm script.txt - The RFTerm script file is used. Either Keyboard or Subscriber/Block mode may be
selected for the wedge when this script file is used.

e Copy RFTerm script.txt - Selecting this option copies the RFTerm supplied script.txt over the currently used
script.txt file. If the copy fails, an error message is displayed.

To use the RFTerm script file:
1. Select the Copy RFTerm script.txt option.
2. Confirm that you wish to copy the file and select Start > Shutdown > Restart when propmted to reboot the RFTerm.

3. After the RFTerm has restarted, return to this screen and verify Using RFTerm script.txt is selected. If not, select it.




4. The Wedge Mode (see below) can now be changed as desired.

Wedge Mode

Note: Freefloat Link One Wedge is used on the Thor VM1 and Thor VM2 equipped with a Windows Embedded
Standard Operating System and all Marathon operating systems. This parameter has no effect on other devices.

Determines the mode for the Freefloat Link One wedge.

* Keyboard - Data from the integrated scanner is passed through the keyboard buffer. This is the only option available
if the default script.txt is selected. (default)

¢ Subscriber/Block - Data from the scanner is transmitted in subscriber/block mode. This method can be much faster
than keyboard mode. Using RFTerm script.txt must be selected first or an error is displayed and the remains in
Keyboard mode.

Spcl Settings

This feature is designed for Honeywell support debugging use only.




Options3

Allows the size and position of the RFTerm window to be specified. By default, RFTerm is displayed in a full window.
Note: This tab was previously labeled Win Size.

Note: There are no configurable options on this screen for devices equipped with a Windows Mobile, Windows XP, Windows 7,
Windows 10, or Windows Embedded Standard operating system. Window Size cannot be adjusted for these devices.

Options3 | saunds | Status | comz |41 »

Window Size
Origin: A ||:| i ||:|
Reduce: '-.-'-.-'||:| H ||:|

Wirtual Keyvboard

| SIP -]

Vi Crientation

IEI Deg EI

¢ From the application menu, select File > Settings.
* A Settings dialog box is displayed.
* Choose the Options3 tab

By default, RFTerm is displayed in a full window (all four settings are 0). There is no error checking for the specified ranges
except:

* Valid entries for each parameter are 0 through 999
¢ The smallest window size is 60x60 pixels regardless of the specified values.

IOrigin T

— e - - s
g File Session Display [I] L i
"

Width

L=

Heigth Reduction

el 5 B 5 we0s e 0A | By
Parameters
Origin X

Specifies the number of pixels to the right of the left origin point to place the left edge of the RFTerm window. Valid
entries are 0 through 999. Default is 0.




Origin Y

Specifies the number of pixels below the top origin point to place the top edge of the RFTerm window. Valid entries are
0 through 999. Default is 0.

Width Reduction

Specifies the number of pixels to the left of the right side screen limit to place the right edge of the RFTerm window.
Valid entries are 0 through 999. Default is 0.

Height Reduction

Specifies the number of pixels above the bottom screen limit to place the bottom edge of the RFTerm window. Valid
entries are 0 through 999. Default is 0.

Virtual Keyboard
Dolphin 70e Black only.

Determines the format of the virtual keyboard to be displayed. In addition to the traditional Windows SIP, the Dolphin
70e Black supports several custom virtual keyboards:

* None - Do not display a virtual keyboard

* Num Left - Display a numeric only virtual keyboard on the left side of the screen

* Num Right - Display a numeric only virtual keyboard on the left side of the screen
¢ Qwerty - Display a QWERTY virtual keyboard

e Emulator - Display an HX2-style virtual keyboard

e SIP - Default. Display the standard Windows SIP.

Note: The host can also send commands to switch the virtual keyboard. See Virtual Keyboards (page 9-12).

VK Orientation
Dolphin 70e Black only.
Determines the orientation of the display:

¢ 0 Deg - Display is not rotated (portrait mode).

* 90 Deg - Display is rotated 90° (landscape mode).

* 180 Deg - Display is rotated 180° (portrait mode).

e 270 Deg - Display is rotated 270° (landscape mode).

Note: Display orientation can also be set outside of RFTerm using the Dolphin Power Tools.




Sounds

Sounds may be configured for various events.

The Alarm on Match Text only sounds when a form is sent to RFTerm from the host. Entering data or moving the cursor around
on the screen does not cause extra beeps when the alarm text remains unchanged. When the user exits and then returns to the
Alarm on Match Text menu, another beep will occur.

Note: Before selecting a user-installed sound or WAV file to be played on a mobile client, the appropriate WAV file or sound file

must be available in the mobile device operating system persistent folder on the storage card. This will ensure the WAV
file is saved instead of discarded when the device is rebooted.

If there is no WAV file in the folder, the text boxes are blank. When there is a WAV file in the folder, the Good Beep/Bad Beep
and Alarm Sound drop down boxes are preset with the default value <DEFAULT> until changed.

Sounds |Status | comi | com2 | L]

Good Sound I::DEFP.ULT:: :|
Ead Sound I::DEF.C'.ULT} :|
&larm Sound I::DEFF'.LILT}' :l

Match Text [ Sound Key

Match Paosition

FLow: IIII Cal: IIII

* From the application menu, select File > Settings.
* A Settings dialog box will be displayed.
¢ Choose the Sounds tab.

Note: The Good Sound pulldown list was previously labeled Good Beep. The Bad Sound pulldown list was previously labeled

Bad Beep. The Match Text/ Sound Key textbox was previous labeled Alarm on Match Text. The Alarm on Match Text
textbox only accepts Match Text. It does not accept Sound Keys.

Parameters

Good Sound

Select the sound from the drop-down box to play when an event such as a good scan occurs. Valid entries are deter-
mined by the available WAV files, plus <NONE> (no sound) and <DEFAULT> (default Windows event sound). The
default is <DEFAULT>.

Note: Before enabling the Good Sound, verify that “Good Scan” sounds are disabled on the mobile client using the
device’s control panel applet (e.g., Volume and Sounds Properties and/or Scanner Properties). When Good
Scan sounds are enabled in RFTerm and on the mobile client, there may be double sounds emitted by the mobile
client during a “Good Beep” function.

Bad Sound

Select the sound from the drop-down box to play when an error such as a bad scan occurs. Valid entries are deter-
mined by the available WAV files, plus <NONE> (no sound) and <DEFAULT> (default Windows event sound). The
default is <DEFAULT>.

Note: Before enabling the Bad Sound verify that “Bad Scan” sounds are disabled on the mobile client using the client’s
Control Panel applet (e.g., Volume and Sounds Properties and/or Scanner Properties). When Bad Scan sounds
are enabled in RFTerm and on the mobile client, there may be double sounds emitted by the mobile client during
a “Bad Beep” function.




Beep on Error

When the Windows System Sound (Exclamation Point) is desired as the Bad Beep sound, the user must change
the WAV file associated with the Operating System on the mobile client (e.g. “Volume and Sounds”). See the
mobile client specific Reference Guide.

Alarm Sound

Select the sound from the drop-down box to play when a when text shown in “Match Text” is displayed. Valid entries
are determined by the available WAV files, plus <NONE> (no sound) and <DEFAULT> (default Windows event sound).
The default is <DEFAULT>.

Note: Before enabling the Alarm Sound Wav, verify that all sounds are disabled on the mobile client using the client’s
Control Panel applet (e.g., Volume and Sounds Properties). When Alarm Sounds are enabled in RFTerm and
on the mobile client, there may be double sounds emitted by the mobile client during an RFTerm Alarm function.

Match Text / Sound Key

Specify the Match Text or Sound Keys. Both may be specified in this textbox; however the Match Text must be speci-
fied first. See below for examples.

Match Text

Enter the text to be displayed on the user’s screen (for example, “Login”) when a response from the user is
desired. The default is blank.

After playing the Alarm Sound WAV and displaying the Match Text, RFTerm then waits for a user response.
Sound Key

Use Sound Key to map various sound causes to the three available sounds.
The Sound Key string is three characters:

The first character is $.

The second character is the cause of the sound:

M for Match

H for Host

U for User

S for Good Scan

L for Laser Error or Bad Scan.

The third character is the sound played:

G for Good Sound

B for Bad Sound

A for Alarm Sound.

Examples

$HA means to assign Host initiated sounds to the Alarm sound

$MA means to assign the Match string sound to the Alarm sound

$LB means to assign the Laser error (scan error) to the Bad sound

$SG means to assign the good Scan sound to Good sound

$UA means to assign User initiated sounds to the Alarm sound.
$HASLBS$SG - Multiple sounds can be assigned by entering Sound Keys consecutively.

Login$HA$SMASUA - Match Text can be used with Sound Keys as long as the Match Text comes before the
Sound Keys in the string.




Alarm Position

Enter the row and column starting position for the Alarm on Match Text to be displayed on the user’s screen. The
default is Row=0 Column=0.

The alarm sounds when it discovers the Alarm on Match Text at the specified row and column. The alarm does not
sound when the Alarm on Match Text is located at any other position.

Sound Events
Host initiated sounds can be triggered by:

* a TN5250/TN3270 message with the Alarm bit set
e aVT220 “bell” command
e a”Bstring

User initiated sounds are triggered by:

¢ the user moving the cursor outside a field and trying to enter data
¢ the user trying to enter a letter into a numeric only field
¢ the user trying to enter data during input inhibit.




Status

Status information is split into two categories.

Status icons that show connection information, the battery level and the state of the keyboard modifier keys may be displayed.
Status icons are not available on devices equipped with a Windows Mobile operating system.

A session menu can be displayed that shows all configured sessions.

[ Options3 ISDunds | Stafus |~'_'||-*

ratatus Icons

Orignkation IN.;.ne :l Colar

Location IBDt-Right :l
[Twan [ con [ wifi [ ] Bat ~ | Key
|
raession Menu

|:| Host Menu
|:| Session Start Conkrol

IN:::ne EI Leaging

Parameters
Status Icons
Orientation
Determines if the status icons are active and, if active, the orientation of the status display.
Valid options are:

* None - Do not display the status icons

* Horizontal - Display the status icons with a horizontal orientation

* Vertical - Display the status icons with a vertical orientation

* Large Horizontal - Display larger status icons with a horizontal orientation
e Large Vertical - Display larger status icons with a vertical orientation.

The default is None (status icons not displayed).
Location

If enabled, determines the location of the status icons on the RFTerm screen. Valid options are:

e Top-Left

¢ Top-Right

* Bottom-Left

¢ Bottom-Right

The default is Bottom-Right.
Color

Determines if the status icons are displayed in color (default) or monotone. The examples below are the color
icons.




WAN
WWAN signal strength is indicated by a four bar icon with a W.

Excellent signal strength
Good signal strength
Fair signal strength

Poor signal strength

BE EE B K

No signal

Con

Displays the status of the connection to the host.

& No currently connected session

%3 Session connected

WiFi

Signal strength for 802.11 radio is indicated by a four bar icon.
Excellent signal strength

Good signal strength

Fair signal strength

Poor signal strength

B bkbkhk

No signal

Bat

Battery power is indicated by a battery icon or a plug icon.

Q0

Excellent battery strength
Good battery strength
Fair battery strength

Poor battery strength

External power source connected

> >00Mm0

y

The status of certain keypress states are indicated.
None of the states below are active.

The Alt keypress state is active

The Ctl keypress state is active

The Shift keypress state is active

= = B E

The CapsLock (or CAPS) keypress state is active




Session Menu
The Session Menu parameters provide options for displaying and swapping between sessions.
Host Menu

When enabled, the Host Menu displays information on sessions on the RFTerm “idle” screen. The Host Menu can
also be displayed in front of an actively connected session by pressing [CtrI][AIt][0]. When the Session Menu is
displayed, pressing keys 1 through 4 switches to that session:

* |f the selected session is not connected, selecting the session starts that session. If the connection fails, the
Host Menu is displayed again.

* |f the selected session is already connected, selecting returns the user back to that session.

When a session is selected, the Host Menu is dismissed. When a session is ended by a regular sign off, the Ses-
sion Menu is automatically displayed, if enabled.

Information displayed, from left to right is:

¢ Active session indicator:
>> for active

__ forinactive

e Session ID, i.e. S1
¢ Connection status:

C for connected
_ for not connected
* Host Name, as entered on Session > Configure screen (optional)
¢ Host IP Address, as entered on Session > Configure screen
Session Start Control
Session Start Control is provided so the user has control over whether or not an auto login session starts.

When enabled, Session Start Control displays a confirmation box before starting the session selected from the
Host Menu. When the popup is displayed:

» Clicking OK or pressing Enter starts the session.
¢ Clicking the X or pressing ESC cancels the session start and returns the user to the Host Menu.

Since auto login sessions may start as soon as the session is selected. By providing the option to start or cancel
the session, the user is provided a rest-point where it is safe to switch off the device without having any open

When disabled, the auto login sessions start without the user having any input.
Logging

The logging feature is designed for Honeywell field service use only.




Com1 and Com2

Note: Com1 and Com2 tabs replace the previous Serial Data tab. With the Com1 and Com2 tabs, each COM port can be
independently configured,

The options for Com1 and Com2 are the same.

| Options3 | Sounds | Status | Coml | coma | J» | Sounds | Status | com1 | Comz2 | L]

Usage: Baud Rate: Data Bits: Usage: Baud Rate: Data Bits:

IInpuI: ] |96|:n:| ~] |s ~] IInput =] |96En:| [~] |s ~]

Tirneouk: Pariky: Stop Biks: Tirneouk: Pariky: Stop Biks:

[10 = were [+ 1 [#] [10 = jwore [+ 1 [+

CTR Control:  RTS Contral: |:| TS Ok CTR Control:  RTS Contral: |:| CTS Ok

IEnaI:-Ie EI IEnaI:uIe EI I:' DSk Ck IEnaI:uIe EI IEnaI:uIe EI I:' OISR, Ctk
SONRCFF Xmit RONROFF Recy SONROF Xt HONROFF Recy

* From the application menu, select File > Settings.
e A Settings dialog box will be displayed.

* Choose the Com1 or Com2 tab.
Should RFTerm be unable to apply any of the COM Port settings, a popup dialog will appear., such as the one below:

Serial Port Error m

Q Com init failed 2 1

COM ports available are dependent on the configuration of the mobile device.

Parameters
Usage
Select the desired communication configuration for the selected COM port:

e Input - The COM port is configured for input only (default).
¢ |/O - The COM port is configured for bi-directional communications

¢ In/Print - The COM port is configured for input and the print settings are controlled from the dialog box displayed by
selecting File > Print Setup > Direct Serial (page 4-6).

e Off - The COM port is disabled.

Baud Rate

Specifies the baud rate at which the COM port operates. The default is 9600.

Data Bits

Specifies the number of data bits to be used. It is one of the following values: 7, or 8 (default).
Timeout

Specifies port timeout in seconds. The default is 10.




Parity

Specifies the parity scheme to be used. It is one of the following values: even, mark, none (default), odd and space.
Stop Bits

Specifies the number of stop bits to be used. It is one of the following values: 1 (default), or 2.

DTR Control

Specifies the data-terminal-ready flow control. The options are enable (default), disable and handshake.

RTS Control

Specifies the request-to-send flow control. The options are enable (default), disable, handshake and toggle.

CTS Out

Specifies if the CTS (clear-to-send) signal is monitored for output flow control. The default is disabled (unchecked).
DSR Out

Specifies if the DSR (data-set-ready) signal is monitored for output flow control. The default is disabled (unchecked).
XonXoff Xmit

Specifies if XON/XOFF flow control is used during transmission. The default is enabled (checked).

XonXoff Recv

Specifies if XON/XOFF flow control is used during reception. The default is enabled (checked).

Stored Forms

A stored form is a combination of valid ANSI/DEC/LXE commands and text that, when executed by RFTerm and displayed on
the screen, appears as a fill-in form.

For all devices with a Windows CE, Windows Embedded Compact, or Windows Mobile operating system

RFTerm places the commands and text that comprise the form in the System/LXE/RFTerm/Stored Forms folder.

For all devices with a Windows XP, Windows 7, Windows 10, or Windows Embedded Standard operating system

RFTerm places the commands and text that comprise the form in the Windows/LXE/Stored Forms folder.

Creating Stored Forms

Stored forms are written by the host application programmer and sent from the host to the mobile client. You cannot create
a form from the mobile client.

The maximum number of stored forms supported by RFTerm is 100 and the maximum size of each stored form is 2K. The
/Stored Forms folder is not automatically cleared upon a mobile client cold boot.

See also: Forms (page 6-3) for command codes for stored forms.







Session Configuration

This section describes various configuration parameters for setting host connections. All these parameters may be set using

the application configuration dialogs accessed from the Session > Configure application menu. Except for “Connection”
parameters, you can change or update any other parameters at any time, whether the host session is connected or discon-

nected.

All configuration attributes are associated with the currently active session. Every session can have a different set of configura-

tion attributes.

For Microsoft Windows 7, Windows 10, and Windows Embedded 7:

It is necessary to run to run RFTerm as an administrator when modifying these settings because RFTerm must be able to

access and make changes to the Windows registry.

Rather than selecting to run as administrator each time, right click on the RFTerm icon and select Properties. Tap the
Compatibility {ab and check Run this program as an administrator. This modification affects the current user only un-

less Change settings for all users is tapped before changing the privilege level.

Connection

The following figures show the Connection tab of the host session configuration dialog.

Connection I Font ICDIDrs I Barcod_<| »

Hosk Tvpe
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Host gddress: |
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Terminal Device: IIBM-SE?B-E :l
| Reset Defaulks I | 3270 Config I
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Note: The dialogs dynamically change depending upon the current selection of “Host Type”.
1. From the application menu, Select Session > Configure or tap the Configure button on the ToolBar.
2. A Configure dialog box is displayed.

3. Choose the Connection tab.

Prerequisites for Connection
Before you make a host connection, you will, at a minimum, need to know:

¢ the alias name or IP address and
¢ the port number of the host system

to properly set up your host session.
Note: There are several new tabs available on the Sessions > Configure screen.

Parameters
Host Type

This is the terminal emulation type required by the host. Your choices are 3270, or VT220. You may select only one
emulation type for the session. Other connection options may change depending upon the host emulation type
selected.

Host Address

This is the address of a host system or an intermediate gateway managing connections to the host system. Enter
either the numeric IP address or the alias hame, using up to 64 characters. This option is case-sensitive.

Host Name

Host name is a field used to identify the session in the Session Menu. Host name is comprised of alphanumeric char-
acters. No host name resolving is performed.

Terminal Device

This is the client type string that determines the specific client to emulate. For 3270 emulations only model 2 screen
geometry is supported. VT220 supports VT52, VT100 and VT220 terminal types. Each host emulation type has its
own default terminal type.

Telnet Port

This is the TCP socket port number to be used to connect to the host system. The default is 23. The range is between
0 and 65535.




Reset Defaults
Tap this button to reset all parameters for the selected session to their default values.
3270, 5250, VT Config

3270 Config 5250 Config YT Config

VT Configuration (page 3-4) 5250 Configuration (page 3-12) 3270 Configuration (page 3-17)

This button, which changes with the Host Type selection, opens a configuration dialog for 3270, 5250 or VT emulation
settings.

KeepAlive

Checking the KeepAlive box will send a message to the host every 2 hours (approximately). If the host responds,
RFTerm knows the host is still present and will keep the socket open. If the host does not respond to repeated Keep-
Alive messages, RFTerm will close the connection to the host. The KeepAlive Interval default value is approximately 2
hours.

By default, KeepAlive is enabled.
Auto Reconnect

Checking this box will cause RFTerm to automatically attempt to reconnect to the host should the connection be termi-
nated by the user or the host, other than signal loss.

Retry on Signal Loss

This option enables an automatic reconnection attempt for this session should the signal be lost. This option is valid
for both RF (802.11) and WWAN connections to the host
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From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
A Configure dialog box will be displayed.

Choose the Connection tab.

Select VT220 as the Host Type, press the VT Config button.

Choose the Keys tab.

Parameters
Backspace

When in character mode, this option configures the backspace key to send either the Delete character or the
Backspace character. The default is Send Delete character.

Enter Key

This option configures the Enter key to send either a carriage return or a carriage return and line feed. The
default is Send Carriage Return.

Keyboard

Specifies the international ASCII character set for use with the VT220 emulation. The default is North Ameri-
can.
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From the application menu, select Session > Configure or tap the Configure button on the ToolBar.

A Configure dialog box will be displayed.

Choose the Connection tab.

Select VT220 as the Host Type, press the VT Config button.

Choose the Screen tab.

Parameters

Background
This option controls the background shade for VT host sessions. The default is Dark.
Columns

This option specifies the number of columns to be set for the VT host session to be 80 or 132. The default
column value is 80 columns. See also: Answerback Columns (page 3-9).

Local Echo
Use this option to select the local echo mode (when in character mode). The default is Off.

e Off - Local echo is off
e On - Local echo is on. Typed text is echoed locally on the mobile client.
* OnCR - Local echo is on. Typed text is echoed locally on the mobile client. CR is added to incoming LF.

Note: previous versions had a Local Echo checkbox which enabled local echo when checked.

Autowrap

Check this option to enable automatic wrapping of text once it reaches the maximum column width. The
default is Enabled (checked).

LF Option
Use this option to control the handling line feed (LF) handling. The default is Normal.

¢ Normal - No special handling is performed.
e LFisCRLF - LF is converted to CRLF is the LF is not already paired with a CR.

Screen Update
Controls the fast screen update enhancement.

Normal - rapid (fast) update enhancements are used. This is the default.

Rapid 1 - Half second timer for last update, packet count of 3 to begin fast update
Rapid 2 - Half second timer for last update, packet count of 5 to begin fast update
Rapid 3 - One second timer for last update, packet count of 3 to begin fast update
Rapid 4 - One second timer for last update, packet count of 5 to begin fast update
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¢ From the application menu, select Session > Configure or tap the Configure button on the ToolBar.

* A Configure dialog box will be displayed.
* Choose the Connection tab.

e Select VT220 as the Host Type, press the VT Config button.

¢ Choose the Options tab.

Parameters

C1 Controls

The C1 Controls option allows the user to select 7 bit or 8 bit ASCII control sequences for the host session.
The default is Send 7-bit.

User Preference Supplemental
This is the user preferred supplemental character set. The default is DEC.

Auto Transmit

Checking this box will cause the entire screen to be sent to the host after the user exits the last field on the
screen. Before sending the data, the Auto Transmit function evaluates the final cursor movement. If the final
cursor movement was caused by a backspace or backtab, the screen is not sent to the host. Note that arrow
keys have no effect on Auto Transmit. The default is blank.

Inclusive End Prot Area

When checked, the End Of Protected Area command is inclusive when a second field exists on the screen, so
that the last location does not become unprotected. The default is unchecked.




Send/Receive Mode

The default is Character.

Always Block - RFTerm will remain in Block mode during and after logon. The host can override the
current mode.

Always Character - RFTerm will remain in Character mode during and after logon. The host can override
the current mode.

Always Line - RFTerm will remain in Line mode during and after logon. The host can override the current
mode.

Block - RFTerm starts in Character mode until a logon connection occurs, and then it remains in Block
mode. The host can override the current mode. A function key press performs an Autosend.

Character - RFTerm starts in Character mode until a logon connection occurs, and then it remains in
Character mode. The host can override the current mode.

Key Buf Char - Character mode with a buffer. The buffer captures incoming messages and forwards them
for processing. If a character fails to be processed, the buffer reattempts processing the buffer contents.
Line - RFTerm starts in Character mode until a logon connection occurs, and then it remains in Line mode.
The host can override the current mode. A function key press performs an Autosend.
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¢ From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
A Configure dialog box will be displayed.

Choose the Connection tab.

Select VT220 as the Host Type, press the VT Config button.

Choose the Answerback tab.

Parameters
Use LXE Format

When this parameter is enabled (checked), the following options to modify the Honeywell formatted string are
available and the Answerback string cannot be directly edited.

When this parameter is disabled (blank), the user can edit the Answerback string as described in Answerback
Message (page 3-9). Other parameters on this dialog box cannot be edited (dimmed). Use IP Address and
Zero Pad are Enabled by default.

Use Secondary ID

Secondary ID and IP Address are mutually exclusive. Checking one disables the controls for the other. The
default Secondary ID is 4 zeros “0000” in alphanumeric format. This is an alternate method to identify the cli-
ent with a 4-digit number. It is automatically padded with zeros if it contains fewer than 4 characters.

Honeywell Session Management

To use RFTerm with any of the Honeywell Session Management products, the Answerback string must be for-
matted to include a Secondary ID.

Special Formatting

Special formatting characters are available to insert device specific ID components into the Secondary ID por-
tion of the answerback string. Refer to Special Formatting for Answerback String (page 3-9) for details.

Use IP Address

Instructs RFTerm to use the IP Address of the device in the Answerback string. This parameter is disabled
when Use Honeywell Format and Use Secondary ID are enabled. This is the default.

Zero Pad

When Zero Pad is enabled (checked), any of the four numbers in the IP address less than 100 will be padded
with leading zeros. For example, with Zero Pad disabled (blank), an IP address is generated as 1.16.253.42.
With Zero Pad enabled, the IP address is generated as 001.016.253.042.




Row
The default is Full Screen.

* None - When selected, sends nothing for the row field in the Answerback string.

¢ Full Screen - When selected, sends 24 for rows in the Answerback string.

* Specify - Allows the row information to be set according to the customer’s needs. Two characters
maximum.

Columns
The default is None.

* None - When selected, sends nothing for the column field in the Answerback string.

* Full Screen - The setting established in the Columns parameter (80 or 132) on the VT Configuration >
Screen tab sets the column size for the Answerback string.

e Specify - Refer to VT Configuration > Screen > Columns parameter. Allows the column size, based on
the setting in the Columns parameter, to be adjusted according to the customer’s needs. Three characters
maximum.

See also: Screen > Columns (page 3-5).
Display
The user may press this button at any time to view the answerback string with the selected options.

Note: The string cannot be edited by the user when Use LXE Format is enabled (checked).

Answerback Message

Host applications may query the VT client for a text message answerback response. This response may be
used to identify the client. The answerback string is automatically generated when requested by the host
using the ENQ command, or by pressing the Display button. The default format contains the following items
after LXE/q/:

The number of rows currently visible on the screen.

The current release number of RFTerm, same as in the About Box.

The IP address of the device, or an optional secondary ID. The default uses the IP address.
Optionally, the number of columns currently visible on the screen.

If Use LXE Format is unchecked, the Answerback Message is an entry field.

Special formatting characters are available to insert device specific ID components into the answerback
string. See below for details.

Special Formatting for Answerback String

The user can enter the % character in either the Secondary ID textbox (when the LXE format is enabled) or
directly in the Answerback Message textbox (when the LXE formatting is disabled) to indicate how to retrieve and
format the portion of the data source to be included in the Answerback string.

The % is followed by a string of special characters in the format %evwwyyz
Where:

v must be one of the following values:

v value Result

0 The string is zero padded.
<space> | The string is space padded.

The next character is not to be formatted and is copied without processing into the string. Special
formatting resumes if another % symbol is encountered in the string.

“.n

; Formatting is stopped for the remainder of the string. In this case, the initial “%” and the
characters are deleted from the string and all other characters are shifted to the left.

ww is the two digit minimum display width.

yy is the two digit precision, the number of digits to display.




If the minimum display width (ww) is greater than the precision (yy) then the string is padded with either zeros
or spaces (depending on the value for v).

When counting digits of precision (yy), only the actual hexadecimal digits are counted. Delimiters such as the
period (in an IP or MAC address) or the dash (GUID) are not counted as digits of precision and are not displayed
in the result.

If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is less
than the available digits in the ID selected, the number of digits returned is the digits of precision.

If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is
greater than the available digits in the ID selected, the number of digits returned is the greater of the available
digits or the minimum display width.

The maximum value is 31 for display width (ww) and digits of precision (yy).

z must be one of the following values:

z value | Result

| Indicates the device’s IP address is used to identify the device. If the IP address is not available, a
string of padding characters results.

G Indicates the GUID is used to identify the device. The conversion beings with the rightmost
character of the GUID and counts to the left. If a GUID is not available from the operating system,
RFTerm generates and stores the GUID in a non-volatile location eliminating the need to generate
the GUID more than once.

M Indicates the MAC address is used to identify the device. The conversion begins with the rightmost
character of the MAC address and moves to the left. Colons are ignored during the conversion. If
the MAC address is not available, a string of padding characters results.

T Indicates the Wavelink Avalanche TID is used to identify the device. If the TID is not available, a
string of padding characters results.

Note: If the above rules are broken (Ww oryy are not two digits, y is an invalid value, etc.) the special formatting

is abandoned and the string is filled with *ERROR*.

Examples

Refer to the following examples for a device with IP address: 10.10.1.23, GUID: 415B1AF5-561F-373D-A244-
80250E3CA123, MAC address: 00:0F:F8:01:23:45 and no Wavelink TID assigned to the device:

String Entered Resolves to
ABC%00808I ABC01010123
ABC% 0808l ABC 1010123
ABC%00804I ABC00000123
ABC%00408lI ABC1010123
ABC%00301I ABCO003
ABC%01012I ABC0001010123
ABC%00404G ABCA123
ABC%00303M ABC345
ABC%00404T ABC0000
ABC%0404T *ERROR*
ABC%;XYZ ABCXYZ
ABC%;%X%Y %Z ABC%X%Y%Z
%:%ABC%00303I %ABC123
ABC%:%% 0303| ABC% 23
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* From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
A Configure dialog box will be displayed.

Choose the Connection tab.

Select VT220 as the Host Type, press the VT Config button.

Choose the Compatibility tab.

Parameters
SEM (Select Editing Extent Mode for VT220)

The session will use the default SEM assignment unless it is overridden by the host. The default is 0 (dis-
play).

Valid values are: 0 = display, 1 = row, 2 = field, 3 = area.

Select DEC Special Graphics into G1

The default is Disabled (unchecked). This option, when enabled, forces the mobile device to be in graphics
mode at all times.

Unlock Keyboard Before End of Data Stream

When unchecked (disabled), the keyboard is locked until the end of the data stream is processed. This is the
default behavior.

When checked (enabled), the keyboard is not locked while the data stream is processed.

Clear Tabs on Clear Screen

Determines if tabs will be cleared when the clear screen command “ESC[2J” is used. The default is None.
Valid values are:

None - Does not clear any preset tabs.

Cursor Only - Clears only the preset cursor tabs.

Column Only - Clears only the preset column tabs.

Cursor and Col - Clears both cursor and column preset tabs.
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From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
A Configure dialog box will be displayed.

Choose the Connection tab.

Select 5250 as the Host Type, press the 5250 Config button.

Choose the Options tab.

Parameters
Device / LU#

This is an optional IBM parameter. It represents a dedicated LU number or name on the server that you might
want to connect through. Default is blank.

Special Formatting

Special formatting characters are available to insert device specific ID components into the Device / LU#
string. Refer to Special Formatting for Device / LU# String (page 3-13).

Auto Transmit
This selection determines the auto transmit behavior of RFTerm.

¢ Off - Auto transmit is disabled. This is the default.

* Last field & pos - This option causes the entire screen to be sent to the host based on data being entered
into the last field and the last position of the field, thereby causing a field exit. The Auto Transmit function
evaluates the final cursor movement. If the final cursor movement was caused by a backspace or backtab,
the screen is not sent to the host. Note that arrow keys have no effect on Auto Transmit.

¢ Last field & exit - This option causes the entire screen to be sent to the host based on the occurrence of
a field exit data in the last field.

* Scan last field - This option causes the entire screen to be sent to the host when data is scanned into the
last field. The data does not have to fill the field to trigger the transmit.

Note: This parameter was previously a check box. Auto transmit was either disabled (unchecked) or enabled
for transmit on last field and position (checked).

Tab = Field Exit

Determines the behavior of the Tab key:

None - Tab does not behave as Field Exit.

Field Exit - Tab behaves has field exit except when in a signed numeric field.

Field Exit Signed Only - Tab behaves has field exit when in a signed numeric field
Field Plus Signed Only - Tab behaves has field plus when in a signed numeric field




Status Line Visible

When Status Line Visible is checked, the status line is displayed on the last viewable row of the mobile client’s
screen. Default is blank.

Support ANSI Login

Checking this box will enable the 5250 session to perform as a limited VT emulation until an IBM terminal type
is negotiated with the host. Default is blank.

Auto Enter
When Auto Enter is checked, an Enter command is sent to the host after a print. Default is blank.
Field Exit on Scan

When Field Exit on Scan is checked, RFTerm performs a Field Exit automatically if a field is being exited due
to a bar code scan. Default is blank.

Special Formatting for Device / LU# String

The user can enter the % character in the Device / LU# textbox to indicate how to retrieve and format the portion
of the data source to be included in the Device / LU# string.

The % is followed by a string of special characters in the format %vwwyyz
Where:
v must be one of the following values:

v value Result
0 The string is zero padded.
<space> | The string is space padded.

The next character is not to be formatted and is copied without processing into the string. Special

formatting resumes if another % symbol is encountered in the string.

Formatting is stopped for the remainder of the string. In this case, the initial “%” and the
characters are deleted from the string and all other characters are shifted to the left.

ww is the two digit minimum display width.

yy is the two digit precision, the number of digits to display.

If the minimum display width (ww) is greater than the precision (yy) then the string is padded with either zeros
or spaces (depending on the value for v).

When counting digits of precision (yy), only the actual hexadecimal digits are counted. Delimiters such as the
period (in an IP or MAC address) or the dash (GUID) are not counted as digits of precision and are not displayed
in the result.

If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is less
than the available digits in the ID selected, the number of digits returned is the digits of precision.

If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is
greater than the available digits in the ID selected, the number of digits returned is the greater of the available
digits or the minimum display width.

The maximum value is 31 for display width (ww) and digits of precision (yy).

z must be one of the following values:

z value | Result

| Indicates the device’s IP address is used to identify the device. If the IP address is not available, a
string of padding characters results.

G Indicates the GUID is used to identify the device. The conversion beings with the rightmost
character of the GUID and counts to the left. If a GUID is not available from the operating system,
RFTerm generates and stores the GUID in a non-volatile location eliminating the need to generate
the GUID more than once.




zvalue | Result

M Indicates the MAC address is used to identify the device. The conversion begins with the rightmost
character of the MAC address and moves to the left. Colons are ignored during the conversion. If
the MAC address is not available, a string of padding characters results.

T Indicates the Wavelink Avalanche TID is used to identify the device. If the TID is not available, a
string of padding characters results.

Note: If the above rules are broken (Ww oryy are not two digits, y is an invalid value, etc.) the special formatting
is abandoned and the string is filled with *ERROR*.

Examples

Refer to the following examples for a device with IP address: 10.10.1.23, GUID: 415B1AF5-561F-373D-A244-
80250E3CA123, MAC address: 00:0F:F8:01:23:45 and no Wavelink TID assigned to the device:

String Entered Resolves to
ABC%00808lI ABC01010123
ABC% 0808l ABC 1010123
ABC%00804| ABC00000123
ABC%00408I ABC1010123
ABC%00301I ABCO003
ABC%01012I ABC0001010123
ABC%00404G ABCA123
ABC%00303M ABC345
ABC%00404T ABCO0000
ABC%0404T *ERROR*
ABC%;XYZ ABCXYZ
ABC%;%X%Y%Z ABC%X%Y%Z
%:%ABC%00303I %ABC123
ABC%:%% 0303| ABC% 23




Compatibility

Note: Previous versions had a Scanner Always On option. 